Mucus plug? TMI

9 posts / 0 new
Last post
mama_to_peanut's picture
Joined: 08/14/10
Posts: 215
Mucus plug? TMI

I'm pretty sure that I have been losing my mucus plug since Sunday. It is like lots of very thick discharge that is dark yellow. Is that what it is? I never lost my plug with my son, so I'm just not experienced in this department!

alwayssmile's picture
Joined: 08/26/07
Posts: 14483

It's usually like thick snot. Very different from my normal pregnancy discharge. If you google image search mucus plug you'll get a lot of very interesting, but good, pictures. Lol

mama_to_peanut's picture
Joined: 08/14/10
Posts: 215

"alwayssmile" wrote:

It's usually like thick snot. Very different from my normal pregnancy discharge. If you google image search mucus plug you'll get a lot of very interesting, but good, pictures. Lol

Yep! Like a really bad sinus infection! Google, here I come! Haha! Thanks Jackie!

moon7starr's picture
Joined: 08/18/08
Posts: 114

I remember last time around thinking it looked like rubber cement! Wink

gabeminamom's picture
Joined: 01/09/11
Posts: 272

Mine came out and that was what started my labor in the early morning of the 25th of October. It looked like a 1-1.5 inch long jelly looking thing. That had clearish and blood in it with stringy tissue hanging off of it. Sorry tmi but that's what mine was. I had NO DOUBT!!! I never lost mine with my other kids. Same as contractions, once they started, the pain, everything about them was different then the BH. So I knew for sure it was labor time.

rmc
rmc's picture
Joined: 07/27/03
Posts: 340

Good luck and ELV's!!!!

haysmama's picture
Joined: 02/23/08
Posts: 1181

I've been losing mine for 2 weeks now. It won't mean labor unless it's bloody. But it sounds like your body is gearing up! Nasty stuff, isn't it?

augustbaby2010's picture
Joined: 01/27/10
Posts: 158

yes. i lost my plug for the last several weeks before giving birth. then, about three days before labor, the plug started to include some blood and was constantly shedding. everytime i wiped, some of the plug was there.

mama_to_peanut's picture
Joined: 08/14/10
Posts: 215

Yeah, I have some everytime I go to the bathroom. So far it does not have any blood. Yes, Beth, it is pretty nasty! I'm really looking forward to my appt tomorrow afternoon to see if I have made any more progress. Last Friday I was 1cm and 50% effaced. I do have an induction scheduled at 5:30 am on black Friday. I'm starting to feel like I won't make it that far!