Cricut Help!!!!!!

14 posts / 0 new
Last post
Breen31806's picture
Joined: 09/05/06
Posts: 1172
Cricut Help!!!!!!

I'm having serious issues with my NEW Cricut machine! I'm using walk in my garden and trying to cut another envelope. The first one I cut was 10" (without real dial size selected) and that envie was too big. So I wanted to cut another one at 9" and it said it wouldn't fit. So I backspaced unloaded and turned off the machine. When I turn on the machine it turns on and off basically clicking. I unplug for 30secs and retry and same thing happens. Any ideas what it could be?

I tried using another Cart (Wild Card) and I think it is the Cartridge that is bad Sad

Joined: 04/08/08
Posts: 807

I don't know, never tried making envies before so I'm no help. Hopefully it is the cartridge so it would at least be easier to replace.

coolmama72's picture
Joined: 10/20/01
Posts: 8185

oh, that sucks that it's a bad cart. email ProvoCraft and see what they say

Joined: 04/08/08
Posts: 807

PC should replace the cart, anyone who has ever had a problem on the Cricut board was able to get their's replaced without a problem.

Breen31806's picture
Joined: 09/05/06
Posts: 1172

Well another update Sad It's not the Carts it is my machine. DH found a reset online we are waiting to see if it works.

gaidinsgirl's picture
Joined: 08/28/06
Posts: 2004

Oh no. I hope it fixes it. I would be so upset if that happened to my new machine Sad

LMCH's picture
Joined: 02/05/07
Posts: 2031

if that doesn't work...try updating the firmware through Design Studio. I had to do that with my baby bug to get my jukebox to work (mentioned this to charys when she got her jukebox). No clue if that would help, but tomorrow, try calling PC customer service...they were helpful when I called.

Joined: 04/08/08
Posts: 807

Oh no, I'm sorry it's the machine. I hope resetting does the trick!

MommyCB's picture
Joined: 05/04/06
Posts: 7623

OH NO! I hope it's nothing serious with the machine. Sad Keep us posted on what the reset does.

Breen31806's picture
Joined: 09/05/06
Posts: 1172

Well the reset didn't work.

I'd try the firmware thingy if I had Design Studio Sad

I have to wait until Monday to call Provo Craft.

It still works sorta but I have to unplug for 30 sec turn on do the cuts I want and then turn off. If I turn it right back on I have to unplug again because it does the power on off crap.

But I don't know if it is cutting my stuff at the right size based on my dial position. It is very frustrating.

It was cute though DH looking online for a reset option. Guess he wants me to scrap this weekend so he can play his game. LOL

LMCH's picture
Joined: 02/05/07
Posts: 2031

you only need the trial version to do the update...and when it first starts up, you just have to click "run in trial mode" or something like that. it took some clicking around, so customer support will be helpful in walking you through it (if that is what it needs)

if that isn't what it needs (since it sounds different from the problems that that fixes), I hope they are able to help you and/or replace your machine.

sewgirly's picture
Joined: 01/01/06
Posts: 1496

Oh no that really stinks!! I hope that they can get it resolved on Monday. Sad

K9Trainer's picture
Joined: 09/25/06
Posts: 4065

What a bummer Kebrina!! Hoping you get it all straight soon.

MommyCB's picture
Joined: 05/04/06
Posts: 7623

man, that's such a bummer!!! Sad

Log in or register to post comments